docs: Add chapter on upgrading, inc. system Python upgrades [#972].
[mediagoblin.git] / guix-env.scm
index df312c8254acb2ed6b4eee02af68ff1cf59805af..04469aafdb3586fc01d0810c7cf8460b02c8f32f 100644 (file)
 ;;;   ./configure --with-python3 --without-virtualenv
 ;;;   make
 ;;;   python3 -m venv --system-site-packages . && bin/python setup.py develop  --no-deps
+;;;   bin/python -m pip install --force-reinstall PasteScript # workaround
+;;;   bin/python -m pip install 'werkzeug<1.0.0' # workaround
+;;;   bin/python -m pip install 'email-validator' # email-validator
 ;;;
-;;; ... wait whaaat, what's that last line!  I thought you said this
+;;; ... wait whaaat, what's that venv line?!  I thought you said this
 ;;; was a reasonable virtualenv replacement!  Well it is and it will
 ;;; be, but there's a catch, and the catch is that Guix doesn't know
 ;;; about this directory and "setup.py dist" is technically necessary
 ;;;   ./devtools/update_extlib.sh
 ;;;   bin/gmg dbupdate
 ;;;   bin/gmg adduser --username admin --password a --email admin@example.com
-;;;   ./lazyserver.sh
+;;;   ./lazyserver.sh <-- won't work
+;;;   CELERY_ALWAYS_EAGER=true ./bin/paster serve paste.ini --reload
 ;;;
 ;;; So anyway, now you can do:
 ;;;  PYTHONPATH="${PYTHONPATH}:$(pwd)" ./runtests.sh
+;;; or:
+;;;  bin/python -m pytest ./mediagoblin/tests --boxed
 ;;;
 ;;; Now notably this is goofier looking than running a virtualenv,
 ;;; but soon I'll do something truly evil (I hope) that will make
@@ -74,6 +80,8 @@
 ;;;
 ;;; Known issues:
 ;;;  - currently fails to upload h264 source video: "GStreamer: missing H.264 decoder"
+;;
+;; TODO: Add PDF support.
 
 (use-modules (ice-9 match)
              (srfi srfi-1)
              (gnu packages rsync)
              (gnu packages ssh)
              (gnu packages time)
+             (gnu packages video)
              (gnu packages version-control)
+             (gnu packages xml)
              ((guix licenses) #:select (expat zlib) #:prefix license:))
 
 ;; =================================================================
        ("python-docutils" ,python-docutils)
        ("python-sqlalchemy" ,python-sqlalchemy)
        ("python-unidecode" ,python-unidecode)
-       ("python-werkzeug" ,python-werkzeug)
+       ;; ("python-werkzeug" ,python-werkzeug)  ; Broken due to missing werkzeug.contrib.atom in 1.0.0.
        ("python-exif-read" ,python-exif-read)
        ("python-wtforms" ,python-wtforms)))
     (home-page "http://mediagoblin.org/")
@@ -197,6 +207,7 @@ media.")
   (version "git")
   (inputs
    `(;;; audio/video stuff
+     ("openh264" ,openh264)
      ("gstreamer" ,gstreamer)
      ("gst-libav" ,gst-plugins-base)
      ("gst-plugins-base" ,gst-plugins-base)