Remove warning message for 4.3.x; we believe the session issues have been
authorkink <kink@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Sun, 30 Mar 2003 10:35:40 +0000 (10:35 +0000)
committerkink <kink@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Sun, 30 Mar 2003 10:35:40 +0000 (10:35 +0000)
fixed. Leave the warning in ReleaseNotes because we don't have enough
testing experience with PHP 4.3.x to be sure about the stability.

git-svn-id: https://svn.code.sf.net/p/squirrelmail/code/trunk/squirrelmail@4702 7612ce4b-ef26-0410-bec9-ea0150e637f0

ChangeLog
INSTALL
ReleaseNotes
src/login.php

index 39e2caf..d3d5691 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -20,8 +20,7 @@ Version 1.4.0 CVS
     by register_globals = off.
   - Added Greek locale. Thanks to George P. Kremmydas 
     <george at kefalonia-ithaki.gr> and Alexandros Vellis <avel at noc.uoa.gr>
-  - Added notes about PHP 4.3.x to documentation, and a gaudy warning message
-    in src/login.php.  Warning can be disabled.
+  - Added notes about PHP 4.3.x to documentation.
   - Fixed \Noselect mailbox detection.
   - Fixed charset decode of base64 encoded strings.
   - Fixed encoding of email addresses in our composed messages.
diff --git a/INSTALL b/INSTALL
index ad5b46a..41196e2 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -25,9 +25,8 @@ Table of Contents:
 
 a. Obtaining and compiling PHP4
   
-  SquirrelMail has not been tested for use with PHP 4.3.x.  The
-  development team does not recommend the use of this software with
-  PHP 4.3.x until further testing can be done.
+  SquirrelMail has not been extensively tested for use with PHP 4.3.x.
+  See the ReleaseNotes file.
 
   Point your favorite webserver at http://www.php.net/version4/ and
   download the source. Untar (tar xvfz filename-you-downloaded.tgz)
index 09a2300..a5e9922 100644 (file)
@@ -38,16 +38,10 @@ A note on PHP 4.3.x
 
 While the developers realize that PHP 4.3.x is the "latest and greatest"
 version of PHP to be available, SquirrelMail has not been extensively
-tested with it.  There may be potential session issues with PHP 4.3.x,
-and PHP by default has a session warning which will need to be disabled
-if you wish to use it with SquirrelMail.
-
-Put simply: The SquirrelMail team does not recommend the use of
-PHP 4.3.x with SquirrelMail at this time.
-
-SquirrelMail will put a large ugly warning about the use of PHP 4.3.x on
-the login screen unless you add "$shootMyFootOff = true;" to 
-config/config_local.php, or downgrade PHP.
+tested with it. We currently believe that SquirrelMail should work on
+PHP 4.3.x but we lack the experience with this new version to be
+absolutely sure. If you want to be safe, or experience problems, you may
+want to downgrade to PHP 4.2.x.
 
 Major updates
 ==============
index fb004ca..684357e 100644 (file)
@@ -94,18 +94,6 @@ if (isset($org_logo) && $org_logo) {
         $width_and_height .= " height=\"$org_logo_height\"";
     }
 }
-global $shootMyFootOff;
-if (check_php_version(4,3) and !isset($shootMyFootOff)) {
-    echo '<center><hr width="75%">' . "\n";
-    echo '<h2>PHP 4.3.x has been detected</h2>' . "\n";
-    echo '</center><p>The SquirrelMail team does not recommend the use of PHP 4.3.x with';
-    echo ' this software.  Please see the <a href="http://www.squirrelmail.org">SquirrelMail';
-    echo ' website</a>, or the documentation that came with SquirrelMail for more information.</p>';
-    echo '<p>This warning can be disabled by either downgrading PHP, or inserting';
-    echo '"$shootMyFootOff = true;" in config/config_local.php.</p>' . "\n";
-    echo '<center><hr width="75%"></center>' . "\n";
-    echo "\n";
-}
 
 echo html_tag( 'table',
     html_tag( 'tr',