Make sure conf.pl doesn't barf on $theme values from old configs.
authorstevetruckstuff <stevetruckstuff@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Wed, 4 Oct 2006 18:58:55 +0000 (18:58 +0000)
committerstevetruckstuff <stevetruckstuff@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Wed, 4 Oct 2006 18:58:55 +0000 (18:58 +0000)
git-svn-id: https://svn.code.sf.net/p/squirrelmail/code/trunk/squirrelmail@11828 7612ce4b-ef26-0410-bec9-ea0150e637f0

config/conf.pl

index 47f59a2..e69b3f0 100755 (executable)
@@ -241,6 +241,11 @@ while ( $line = <FILE> ) {
             $sub =~ s/\'\]//;
             $sub =~ s/^fontsets\[\'//;
             $fontsets{$sub} = $options[1];
+        } elsif ( $options[0] =~ /^theme\[[0-9]+\]\[['"]PATH|NAME['"]\]/ ) {
+               ##
+               ## $color themes are no longer supported.  Please leave this
+               ## so conf.pl doesn't barf if it encounters a $theme.
+               ##
         } elsif ( $options[0] =~ /^ldap_server\[[0-9]+\]/ ) {
             $sub = $options[0];
             $sub =~ s/\]//;