This might fix the problem with adding slashes when composing messages
authorlkehresman <lkehresman@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Tue, 8 Feb 2000 12:18:17 +0000 (12:18 +0000)
committerlkehresman <lkehresman@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Tue, 8 Feb 2000 12:18:17 +0000 (12:18 +0000)
git-svn-id: https://svn.code.sf.net/p/squirrelmail/code/trunk/squirrelmail@196 7612ce4b-ef26-0410-bec9-ea0150e637f0

functions/smtp.php
src/compose.php
src/options.php

index 5a71dc5..e9a86fd 100644 (file)
         fputs ($fp, "--".mimeBoundary()."\n");
         fputs ($fp, "Content-Type: text/plain; charset=ISO-8859-1\n");
         fputs ($fp, "Content-Transfer-Encoding: 8bit\n\n");
-        fputs ($fp, "$body\n");
+        fputs ($fp, stripslashes($body) . "\n");
         attachFiles($fp);
         fputs ($fp, "\n--".mimeBoundary()."--\n");
      } else {
-       fputs ($fp, "$body\n");
+       fputs ($fp, stripslashes($body) . "\n");
      }
    }
 
index 8f57897..2af8b6b 100644 (file)
       echo "   <TR>\n";
       echo "      <TD BGCOLOR=\"$color[4]\" COLSPAN=2>\n";
       if ($use_signature == true)
-         echo "         &nbsp;&nbsp;<TEXTAREA NAME=body ROWS=20 COLS=\"$editor_size\" WRAP=HARD>$body\n\n$signature</TEXTAREA><BR>";
+         echo "         &nbsp;&nbsp;<TEXTAREA NAME=body ROWS=20 COLS=\"$editor_size\" WRAP=HARD>". $body . "\n\n".$signature."</TEXTAREA><BR>";
       else
-         echo "         &nbsp;&nbsp;<TEXTAREA NAME=body ROWS=20 COLS=\"$editor_size\" WRAP=HARD>$body</TEXTAREA><BR>\n";
+         echo "         &nbsp;&nbsp;<TEXTAREA NAME=body ROWS=20 COLS=\"$editor_size\" WRAP=HARD>".$body."</TEXTAREA><BR>\n";
       echo "      </TD>\n";
       echo "   </TR>\n";
       echo "   <TR><TD COLSPAN=2 ALIGN=CENTER><INPUT TYPE=SUBMIT NAME=send VALUE=\"";
index 8568973..6adb81e 100644 (file)
    echo "         </FONT>";
    echo "      </TD>";
    echo "   </TR>";
-   echo "</TABLE>";
 
    // LEFT_REFRESH
    echo "   <TR>";