Undo fix for PHP 4.0.4 since SquirrelMail doesn't work reliably with 4.0.4
authorkink <kink@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Fri, 7 Mar 2003 15:33:05 +0000 (15:33 +0000)
committerkink <kink@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Fri, 7 Mar 2003 15:33:05 +0000 (15:33 +0000)
anyway.

git-svn-id: https://svn.code.sf.net/p/squirrelmail/code/trunk/squirrelmail@4609 7612ce4b-ef26-0410-bec9-ea0150e637f0

plugins/listcommands/setup.php

index b432ced..e055bf8 100644 (file)
@@ -40,8 +40,10 @@ function plugin_listcommands_menu() {
     foreach ($message->rfc822_header->mlist as $cmd => $actions) {
 
        /* I don't know this action... skip it */
-        /* array_key_exists works only in >= 4.1 */
-        if ( !in_array($cmd, array_keys($fieldsdescr)) ) {
+       if ( ( function_exists('array_key_exists') &&       /* PHP >= 4.1 */
+               !array_key_exists($cmd, $fieldsdescr) ) ||
+             !key_exists($cmd, $fieldsdescr)                /* PHP == 4.0.6 */
+        ) {
             continue;
         }