Fix requirements to reflect actual requirements according to Marc.
authorkink <kink@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Fri, 7 Mar 2003 15:26:45 +0000 (15:26 +0000)
committerkink <kink@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Fri, 7 Mar 2003 15:26:45 +0000 (15:26 +0000)
git-svn-id: https://svn.code.sf.net/p/squirrelmail/code/trunk/squirrelmail@4608 7612ce4b-ef26-0410-bec9-ea0150e637f0

ChangeLog
INSTALL
UPGRADE
themes/random.php

index f55fdcd..a973dea 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -27,7 +27,6 @@ Version 1.4.0 CVS
   - Fixed folder creation for Courier using Autoconfig options.
   - Fixed encoded string handling inside MDN notifications.
   - Fixed unfold header routine in imap_messages (for mailbox_display).
-  - Make listcommands work with PHP versions 4.0.4 & 4.0.5.
   - Fixed subject_line hook.
   - Fixed sqgetGlobalVar switching.
   - Fixed handling of encoding/decoding strings.
@@ -37,7 +36,8 @@ Version 1.4.0 CVS
   - Fixed uninitialized indices when parsing attachments.
   - Support text/directory MIME-type for vCards (RFC 2425).
   - Added Arabic locale. Thanks to Asrar Abbasi <asrar at canasoft.net> and
-    Naveed Saqib <naveed.saqib at biznas.com>
+    Naveed Saqib <naveed.saqib at biznas.com>.
+  - Update required PHP version in documentation to 4.0.6.
 
 Version 1.4.0 RC 2a
 -------------------
diff --git a/INSTALL b/INSTALL
index 3d9695e..ad5b46a 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -20,10 +20,8 @@ Table of Contents:
   to run as CGI under Apache. How you end up doing this is up to you
   (your mileage may vary).
 
-  NOTE: The new plugin architecture required the use of some functions 
-  which are not in all versions of PHP4. You will need at least 
-  PHP4 v4.0.4. If you need to upgrade please go ahead and install the
-  latest release version of PHP4.
+  You will need at least PHP v4.0.6. If you need to upgrade please go
+  ahead and install it now.
 
 a. Obtaining and compiling PHP4
   
diff --git a/UPGRADE b/UPGRADE
index 5de1f0f..3067009 100644 (file)
--- a/UPGRADE
+++ b/UPGRADE
@@ -7,7 +7,7 @@ using a previous version (0.1 or 0.2), it is suggested that you just start
 from scratch and configure your settings as if it was your first install.
 
 NOTE: The new plugin architecture required the use of some functions which
-are not in all versions of PHP4. You will need at least PHP 4.0.4. If you
+are not in all versions of PHP4. You will need at least PHP 4.0.6. If you
 need to upgrade please go ahead and install the latest release version of
 PHP4.
 
index 38094b7..b6af679 100755 (executable)
@@ -26,8 +26,9 @@ if (!sqsession_is_registered('random_theme_good_theme')) {
             $good_themes[] = $data['PATH'];
         }
     }
-    if (count($good_themes) == 0)
-    $good_themes[] = '../themes/default.php';
+    if (count($good_themes) == 0) {
+        $good_themes[] = '../themes/default.php';
+    }
     $which = mt_rand(0, count($good_themes));
     $random_theme_good_theme = $good_themes[$which];
     sqsession_register($random_theme_good_theme, 'random_theme_good_theme');