New Dev version strings.
authorebullient <ebullient@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Fri, 4 Apr 2003 04:00:36 +0000 (04:00 +0000)
committerebullient <ebullient@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Fri, 4 Apr 2003 04:00:36 +0000 (04:00 +0000)
slight include order change to avoid potential E_ALL message.

git-svn-id: https://svn.code.sf.net/p/squirrelmail/code/trunk/squirrelmail@4719 7612ce4b-ef26-0410-bec9-ea0150e637f0

functions/strings.php

index 58d135e..8f278b1 100644 (file)
  * $Id$
  */
 
-require_once(SM_PATH . 'functions/global.php');
 
 /**
  * SquirrelMail version number -- DO NOT CHANGE
  */
 global $version;
-$version = '1.4.1 [CVS]';
+$version = '1.5.0 [CVS]';
 
 /** 
  * SquirrelMail internal version number -- DO NOT CHANGE
  * $sm_internal_version = array (release, major, minor)
  */
 global $SQM_INTERNAL_VERSION;
-$SQM_INTERNAL_VERSION = array(1,4,1);
+$SQM_INTERNAL_VERSION = array(1,5,0);
+
 
+/**
+ * There can be a circular issue with includes, where the $version string is
+ * referenced by the include of global.php, etc. before it's defined.
+ * For that reason, bring in global.php AFTER we define the version strings.
+ */
+require_once(SM_PATH . 'functions/global.php');
 
 /**
  * Wraps text at $wrap characters