Can't require config.php before strings.php since default config references $version.
authortassium <tassium@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Tue, 31 Dec 2002 15:50:07 +0000 (15:50 +0000)
committertassium <tassium@7612ce4b-ef26-0410-bec9-ea0150e637f0>
Tue, 31 Dec 2002 15:50:07 +0000 (15:50 +0000)
git-svn-id: https://svn.code.sf.net/p/squirrelmail/code/trunk/squirrelmail@4337 7612ce4b-ef26-0410-bec9-ea0150e637f0

include/validate.php

index 62e7e8c..a471ce5 100644 (file)
@@ -31,6 +31,7 @@ session_write_close();
 
 /* SquirrelMail required files. */
 require_once(SM_PATH . 'class/mime.class.php');
+require_once(SM_PATH . 'functions/strings.php');
 require_once(SM_PATH . 'config/config.php');
 
 /* set the name of the session cookie */
@@ -44,7 +45,6 @@ session_start();
 
 require_once(SM_PATH . 'functions/i18n.php');
 require_once(SM_PATH . 'functions/auth.php');
-require_once(SM_PATH . 'functions/strings.php');
 require_once(SM_PATH . 'functions/global.php');
 
 is_logged_in();