Search was broken. fixed. List all is weird however, it works but does not alternate...
[squirrelmail.git] / plugins / squirrelspell / sqspell_options.php
index 86c75cd..8311678 100644 (file)
@@ -1,35 +1,46 @@
 <?php
-/**
-   SQSPELL_OPTIONS.PHP
-   --------------------
-   Main wrapper for the options interface.
-                                                               **/
-// Set a couple of constants. Don't change these, the setuppable stuff is
-// in sqspell_config.php
-$SQSPELL_DIR="squirrelspell";
-$SQSPELL_CRYPTO=false;
 
-// Load some necessary stuff.
-chdir("..");
-include("../src/validate.php");
-include("../src/load_prefs.php");
-include("../functions/strings.php");
-include("../functions/page_header.php");
-include ("$SQSPELL_DIR/sqspell_config.php");
-require ("$SQSPELL_DIR/sqspell_functions.php");
+   /**
+    **  sqspell_options.php -- Main wrapper for the options interface.
+    **
+    **  Copyright (c) 1999-2002 The SquirrelMail development team
+    **  Licensed under the GNU GPL. For full terms see the file COPYING.
+    **
+    **
+    **
+    **  $Id$
+    **/
 
-// Access the module needed
-//
-if (!$MOD) $MOD="options_main";
-
-// see if someone is attempting to be nasty by trying to get out of the
-// modules directory, although it probably wouldn't do them any good,
-// since every module has to end with .mod.php. Still, they deserve
-// to be warned. ;)
-if (strstr($MOD, ".") || strstr($MOD, "/") || strstr($MOD, "%")){
-       echo "SECURITY BREACH ON DECK 5! CMDR TUVOK AND SECURITY TEAM REQUESTED.";
+    /*
+    ** Set a couple of constants. Don't change these, the setuppable stuff is
+    ** in sqspell_config.php
+    */
+    $SQSPELL_DIR='squirrelspell';
+    $SQSPELL_CRYPTO=FALSE;
+    
+    /* Load some necessary stuff. */
+    chdir('..');
+    require_once('../src/validate.php');
+    require_once('../src/load_prefs.php');
+    require_once('../functions/strings.php');
+    require_once('../functions/page_header.php');
+    require_once("$SQSPELL_DIR/sqspell_config.php");
+    require_once("$SQSPELL_DIR/sqspell_functions.php");
+    
+    /* Access the module needed */
+    if (!$MOD) 
+        $MOD = 'options_main';
+    
+    /*
+    ** see if someone is attempting to be nasty by trying to get out of the
+    ** modules directory, although it probably wouldn't do them any good,
+    ** since every module has to end with .mod. Still, they deserve
+    ** to be warned. ;)
+    */
+    if (strstr($MOD, ".") || strstr($MOD, "/") || strstr($MOD, "%")){
+       echo _("SECURITY BREACH ON DECK 5! CMDR TUVOK AND SECURITY TEAM REQUESTED.");
         exit;
-}
-// load the stuff already.
-include ("$SQSPELL_DIR/modules/$MOD.mod.php");
+    }
+    /* load the stuff already. */
+    require_once("$SQSPELL_DIR/modules/$MOD.mod");
 ?>