New get_plugin_version() function, and a couple places to use it.
[squirrelmail.git] / plugins / spamcop / README
index 82af1ae..c80da44 100755 (executable)
@@ -26,9 +26,6 @@ can then just delete the forwarder and get a new one.  Make sure to use the
 forwarder to sign up for SpamCop and get the required information for the
 plugin.
 
-This plugin is also an example of how to use the identity hooks.  Just open
-up setup.php and read the comments.
-
 
 Installation
 ============
@@ -36,3 +33,19 @@ Installation
 Go back to the main directory, run configure and add the plugin.
 
 
+API
+===
+
+SquirrelMail hooks used by plugin:
+* loading_prefs
+* optpage_register_block
+* read_body_header_right
+* compose_send
+
+Plugin preference keys:
+* spamcop_enabled
+* spamcop_delete
+* spamcop_save
+* spamcop_method
+* spamcop_type
+* spamcop_id