Correct value of undefined hostname
[squirrelmail.git] / include / constants.php
index 3ae1327..79fcaba 100644 (file)
@@ -6,7 +6,7 @@
  * Loads constants used by the rest of the SquirrelMail source.
  *
  * Before 1.5.2 script was stored in functions/constants.php
- * @copyright © 1999-2006 The SquirrelMail Project Team
+ * @copyright © 1999-2007 The SquirrelMail Project Team
  * @license http://opensource.org/licenses/gpl-license.php GNU Public License
  * @version $Id$
  * @package squirrelmail
 
 /** @ignore */
 
+/**
+ * SquirrelMail version number -- DO NOT CHANGE
+ * @since 1.5.2
+ */
+define('SM_VERSION', '1.5.2 [SVN]');
+
 /**************************************************************/
 /* Set values for constants used by SquirrelMail preferences. */
 /**************************************************************/
 
 /**
+ * Define constants for SquirrelMail debug modes.
+ * Note that these are binary so that modes can be
+ * mixed and matched, and they are also ordered from
+ * minor to severe.  When adding new modes, please
+ * order them in a sensical way (MODERATE is the 10th
+ * bit; ADVANCED is the 20th bit).
+ * @since 1.5.2
+ */
+define('SM_DEBUG_MODE_OFF', 0);             // complete error suppression
+define('SM_DEBUG_MODE_SIMPLE', 1);          // PHP E_ERROR
+define('SM_DEBUG_MODE_MODERATE', 512);      // PHP E_ALL
+define('SM_DEBUG_MODE_ADVANCED', 524288);   // PHP E_ALL plus log errors intentionally suppressed
+define('SM_DEBUG_MODE_STRICT', 536870912);  // PHP E_STRICT
+
+/**
  * Define basic, general purpose preference constants.
  * @since 1.2.0
  */
@@ -51,6 +72,10 @@ define('SMPREF_UNSEEN_NORMAL', 5);  // Only normal folders (since 1.2.5)
 define('SMPREF_UNSEEN_ONLY', 1);
 define('SMPREF_UNSEEN_TOTAL', 2);
 
+define('SMPREF_MAILBOX_SELECT_LONG', 0);
+define('SMPREF_MAILBOX_SELECT_INDENTED', 1);
+define('SMPREF_MAILBOX_SELECT_DELIMITED', 2);
+
 /**
  * Define constants for time/date display preferences.
  * @since 1.2.0
@@ -167,3 +192,9 @@ define('SQ_TYPE_ARRAY', 'array');
 define('SQ_PHP_TEMPLATE', 'PHP_');
 define('SQ_SMARTY_TEMPLATE', 'Smarty_');
 
+/**
+ * Used by plugins to indicate an incompatibility with a SM version
+ * @since 1.5.2
+ */
+define('SQ_INCOMPATIBLE', 'INCOMPATIBLE');
+