Added option to do data and attachment directory hashing, up to four levels. Will...
[squirrelmail.git] / plugins / squirrelspell / INSTALL
1 SquirrelSpell-v0.3.1
2 ---------------------
3
4 Untar SquirrelSpell into your squirrelmail/plugins directory. Modify the 
5 sqspell_config.php file making sure you have ispell or aspell
6 available on your system and located in PHP's path. The squirrelspell
7 doesn't check for that and if it is not available, you're just going to
8 get a "No errors found"  message every time. :) Quite pleasing, but not
9 very useful.
10
11 Read files in "doc" directory -- they explain some features.
12
13 Enable the plugin either by hand or by running the configure script from
14 your squirrelmail install directory.
15
16 Enjoy and report bugs. ;)
17
18 This is an options commented sqspell_config.php
19
20 <?php
21
22    /**
23     **  sqspell_config.php -- SquirrelSpell Configuration file.
24     **
25     **  Copyright (c) 1999-2000 The SquirrelMail development team
26     **  Licensed under the GNU GPL. For full terms see the file COPYING.
27     **
28     **
29     **
30     **  $Id$
31     **/
32
33     /* Just for poor wretched souls with E_ALL. :) */
34     global $username, $data_dir;
35
36     /**
37        SPELL-CHECKING APPLICATIONS:
38        ----------------------------
39        This feature was added/changed in 0.3. Use this array to set up
40        which dictionaries are available to users. If you only have
41        English spellchecker on your system, then let this line be:
42
43        $SQSPELL_APP = array("English" => "ispell -a");
44
45        or
46
47        $SQSPELL_APP = array("English" => "/usr/local/bin/aspell -a");
48
49        Sometimes you have to specify full path for PHP to find it.
50        Aspell is a better spell-checker than Ispell, so you're encouraged
51        to use it.
52
53        If you want to have more than one dictionary available to users,
54        configure the array to look something like this:
55
56        $SQSPELL_APP = array(
57                         "English" => "aspell -a",
58                             "Russian" => "ispell -d russian -a",
59                         ...
60                         "Swahili" => "ispell -d swahili -a"
61                        );
62
63        Watch the commas, making sure there isn't one after your last
64        dictionary declaration. Also, make sure all these dictionaries
65        are available on your system before you specify them here.
66
67        Whatever your setting is, don't omit the "-a" flag.
68
69     **/
70     $SQSPELL_APP = array('English' => 'ispell -a');
71
72     /**
73        DEFAULT DICTIONARY
74        -------------------
75        Even if you're only running one dictionary, still specify which one
76        is the default. Watch the case -- it has to be exactly as in array
77        you declared in $SQSPELL_APP.
78     **/
79     $SQSPELL_APP_DEFAULT='English';
80
81     /**
82        USER DICTIONARY:
83        -----------------
84        $SQSPELL_WORDS_FILE is a location and mask of a user dictionary file.
85        The default setting should be OK for most everyone. Read PRIVACY and
86        CRYPTO in the "doc" directory.
87     **/
88     $SQSPELL_WORDS_FILE = "$data_dir/$username.words";
89
90     /**
91        CASE SENSITIVITY:
92        ------------------
93        Use $SQSPELL_EREG="ereg" for case-sensitive matching of user
94        dictionary, or $SQSPELL_EREG="eregi" for case-insensitive
95        matching. It is advised to use case-sensitive matching.
96     **/
97     $SQSPELL_EREG="ereg";
98
99     /**
100        SOUP NAZI (AVOIDING BAD BROWSERS)
101        -------------------------------------
102        Since some browsers choke on JavaScript, here is an option to disable the
103        browsers with known problems. All you do is add some part of an USER_AGENT
104        string of an offending browser which you want to disable and users will not
105        know about this plugin. E.g. browsers with "Mozilla/4.61 (Macintosh, I, PPC)"
106        USER_AGENT string will get weeded out if you provide "Macintosh" in the
107        config string.
108
109        Mozilla/2 -- You're kidding, right?
110        Mozilla/3 -- known not to work
111        Opera -- known not to work
112        Macintosh -- Netscape 4.x on Macintosh chokes for some reason.
113                     Adding until resolved.
114     **/
115     $SQSPELL_SOUP_NAZI = 'Mozilla/3, Mozilla/2, Opera 4, Opera/4, Macintosh';
116 ?>