Replacing tabs with spaces
[squirrelmail.git] / plugins / squirrelspell / INSTALL
CommitLineData
38c5802f 1SquirrelSpell plugin
2--------------------
849bdf42 3
2b5a7157 4Untar SquirrelSpell into your squirrelmail/plugins directory. Modify the
5sqspell_config.php file making sure you have ispell or aspell
849bdf42 6available on your system and located in PHP's path. The squirrelspell
7doesn't check for that and if it is not available, you're just going to
38c5802f 8get a "No errors found" message every time. :) Quite pleasing, but not
849bdf42 9very useful.
10
11Read files in "doc" directory -- they explain some features.
12
13Enable the plugin either by hand or by running the configure script from
14your squirrelmail install directory.
15
38c5802f 16NOTE: If you are using php >= 4.3.0 squirrelspell should work in safe mode.
17Otherwise, you may have to disable safe mode for the squirrelspell directory.
18 APACHE CONF EXAMPLE:
19 <Directory /webroot/squirrelmail/plugins/squirrelspell>
20 php_admin_value safe_mode 0
21 </Directory>
22
23
849bdf42 24Enjoy and report bugs. ;)
9804bcde 25
2b5a7157 26This is an options commented sqspell_config.php
9804bcde 27
28<?php
29
30 /**
31 ** sqspell_config.php -- SquirrelSpell Configuration file.
32 **
33 ** Copyright (c) 1999-2000 The SquirrelMail development team
34 ** Licensed under the GNU GPL. For full terms see the file COPYING.
35 **
36 **
37 **
38 ** $Id$
39 **/
40
41 /* Just for poor wretched souls with E_ALL. :) */
42 global $username, $data_dir;
43
44 /**
45 SPELL-CHECKING APPLICATIONS:
46 ----------------------------
47 This feature was added/changed in 0.3. Use this array to set up
48 which dictionaries are available to users. If you only have
49 English spellchecker on your system, then let this line be:
50
51 $SQSPELL_APP = array("English" => "ispell -a");
52
53 or
54
55 $SQSPELL_APP = array("English" => "/usr/local/bin/aspell -a");
56
57 Sometimes you have to specify full path for PHP to find it.
58 Aspell is a better spell-checker than Ispell, so you're encouraged
59 to use it.
60
61 If you want to have more than one dictionary available to users,
62 configure the array to look something like this:
63
64 $SQSPELL_APP = array(
65 "English" => "aspell -a",
66 "Russian" => "ispell -d russian -a",
67 ...
68 "Swahili" => "ispell -d swahili -a"
69 );
70
71 Watch the commas, making sure there isn't one after your last
72 dictionary declaration. Also, make sure all these dictionaries
73 are available on your system before you specify them here.
74
75 Whatever your setting is, don't omit the "-a" flag.
76
77 **/
78 $SQSPELL_APP = array('English' => 'ispell -a');
79
80 /**
81 DEFAULT DICTIONARY
82 -------------------
83 Even if you're only running one dictionary, still specify which one
84 is the default. Watch the case -- it has to be exactly as in array
85 you declared in $SQSPELL_APP.
86 **/
87 $SQSPELL_APP_DEFAULT='English';
88
89 /**
90 USER DICTIONARY:
91 -----------------
92 $SQSPELL_WORDS_FILE is a location and mask of a user dictionary file.
93 The default setting should be OK for most everyone. Read PRIVACY and
94 CRYPTO in the "doc" directory.
95 **/
96 $SQSPELL_WORDS_FILE = "$data_dir/$username.words";
97
98 /**
99 CASE SENSITIVITY:
100 ------------------
101 Use $SQSPELL_EREG="ereg" for case-sensitive matching of user
102 dictionary, or $SQSPELL_EREG="eregi" for case-insensitive
103 matching. It is advised to use case-sensitive matching.
104 **/
105 $SQSPELL_EREG="ereg";
106
107 /**
108 SOUP NAZI (AVOIDING BAD BROWSERS)
109 -------------------------------------
110 Since some browsers choke on JavaScript, here is an option to disable the
111 browsers with known problems. All you do is add some part of an USER_AGENT
112 string of an offending browser which you want to disable and users will not
113 know about this plugin. E.g. browsers with "Mozilla/4.61 (Macintosh, I, PPC)"
114 USER_AGENT string will get weeded out if you provide "Macintosh" in the
115 config string.
116
117 Mozilla/2 -- You're kidding, right?
118 Mozilla/3 -- known not to work
119 Opera -- known not to work
120 Macintosh -- Netscape 4.x on Macintosh chokes for some reason.
121 Adding until resolved.
122 **/
123 $SQSPELL_SOUP_NAZI = 'Mozilla/3, Mozilla/2, Opera 4, Opera/4, Macintosh';
38c5802f 124?>