update README
authorvunhat_minh <vunhat_minh@dwango.co.jp>
Fri, 22 Aug 2014 04:13:22 +0000 (13:13 +0900)
committervunhat_minh <vunhat_minh@dwango.co.jp>
Fri, 22 Aug 2014 04:13:22 +0000 (13:13 +0900)
README.rst
docs/index.rst

index 38523ba..1d99ad2 100644 (file)
@@ -56,22 +56,23 @@ For debian-based distros, these can be installed with
 .. code:: bash\r
 \r
     sudo apt-get install python-dev libjpeg libjpeg-dev libfreetype6 libfreetype6-dev zlib1g-dev\r
-    sudo pip install rainbowstream\r
 \r
 Besides, Mac OSX Maverick with Xcode 5.1 has a well-known `clang unknown argument`_ problem with\r
 the ``Pillow`` package installation - a dependency of this app.\r
-If you are in this case, I recommend take a look at `Issue #10`_ and let me know if this workaround doesn't work for you.\r
+If you are in this case, I recommend taking a look at `Issue #10`_ and let me know if this workaround doesn't work for you.\r
 \r
 .. code:: bash\r
 \r
     export ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future\r
-    sudo pip install rainbowstream\r
 \r
-If installation in *the quick way* doesn't work, first try to use the *virtualenv way* before creating an issue.\r
-In the issue, please provide following information:\r
+If installation in *the quick way* doesn't work:\r
+\r
+-  `sudo pip uninstall rainbowstream`\r
+-  use the *virtualenv way* above\r
+-  `create an issue`_ and provide:\r
 \r
- Your OS\r
- Your Python version\r
+  + Your OS\r
+  + Your Python version\r
 \r
 Usage\r
 -----\r
index a3a8420..004f3aa 100644 (file)
@@ -42,16 +42,29 @@ Use `virtualenv`_
 Troubleshooting\r
 ^^^^^^^^^^^^^^^\r
 \r
-If you use Linux, you might need to install the python-dev package if you haven't already.\r
+If you use Linux, you might need to install some packages if you haven't already. \r
 For debian-based distros, these can be installed with\r
 \r
 .. code:: bash\r
 \r
-    sudo apt-get install python-dev\r
+    sudo apt-get install python-dev libjpeg libjpeg-dev libfreetype6 libfreetype6-dev zlib1g-dev\r
 \r
 Besides, Mac OSX Maverick with Xcode 5.1 has a well-known `clang unknown argument`_ problem with\r
 the ``Pillow`` package installation - a dependency of this app.\r
-If you are in this case, I recommend take a look at `Issue #10`_ and let me know if the workaround doesn't work for you.\r
+If you are in this case, I recommend taking a look at `Issue #10`_ and let me know if this workaround doesn't work for you.\r
+\r
+.. code:: bash\r
+\r
+    export ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future\r
+\r
+If installation in *the quick way* doesn't work:\r
+\r
+-  `sudo pip uninstall rainbowstream`\r
+-  use the *virtualenv way* above\r
+-  `create an issue`_ and provide:\r
+\r
+  + Your OS\r
+  + Your Python version\r
 \r
 Usage\r
 -----\r