bumped version
[rainbowstream.git] / setup.py
index 275a9a7..c5ab2d2 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -1,20 +1,19 @@
 from setuptools import setup, find_packages
 
-version = '0.0.1'
+version = '0.2.8'
 
 install_requires = [
-    "SQLAlchemy",
-    "pysqlite",
-    "colorama",
-    "pyfiglet",
     "python-dateutil",
-    "termcolor",
-    "twitter"
+    "requests",
+    "pyfiglet",
+    "SQLAlchemy",
+    "twitter",
+    "Pillow",
 ]
 
 setup(name='rainbowstream',
       version=version,
-      description="A colorful terminal-based client for Twitter. Streaming also supported",
+      description="A smart and nice Twitter client on terminal.",
       long_description=open("./README.rst", "r").read(),
       classifiers=[
           "Development Status :: 5 - Production/Stable",
@@ -24,18 +23,14 @@ setup(name='rainbowstream',
           "Operating System :: OS Independent",
           "Programming Language :: Python :: 2.6",
           "Programming Language :: Python :: 2.7",
-          "Programming Language :: Python :: 3.2",
-          "Programming Language :: Python :: 3.3",
-          "Programming Language :: Python :: 3.4",
           "Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
           "Topic :: Utilities",
           "License :: OSI Approved :: MIT License",
       ],
       keywords='twitter, command-line tools, web 2.0, stream API',
       author='Vu Nhat Minh',
-      author_email='nhatminh_179@hotmail.com',
+      author_email='nhatminh179@gmail.com',
       url='https://github.com/DTVD/rainbowstream',
-      download_url='https://github.com/DTVD/rainbowstream/tarball/0.0.1',
       license='MIT License',
       packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
       include_package_data=True,
@@ -44,6 +39,6 @@ setup(name='rainbowstream',
       entry_points="""
       # -*- Entry points: -*-
       [console_scripts]
-      rainbow=rainbowstream.rainbow:fly
+      rainbowstream=rainbowstream.rainbow:fly
       """,
       )