Mac emoji support
[rainbowstream.git] / setup.py
index 294fd86..ac0c342 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -1,19 +1,29 @@
 from setuptools import setup, find_packages
-import sys
+import os
+import os.path
 
-version = '0.3.4'
+# Bumped version
+version = '0.9.9'
 
+# Require
 install_requires = [
     "python-dateutil",
+    "arrow",
     "requests",
     "pyfiglet",
-    "SQLAlchemy",
     "twitter",
     "Pillow",
 ]
-if sys.version[0] == "2":
-    install_requires += ["pysqlite"]
 
+# Copy default config if not exists
+default = os.path.expanduser("~") + os.sep + '.rainbow_config.json'
+if not os.path.isfile(default):
+    cmd = 'cp rainbowstream/colorset/config ' + default
+    os.system(cmd)
+    cmd = 'chmod 777 ' + default
+    os.system(cmd)
+
+# Setup
 setup(name='rainbowstream',
       version=version,
       description="A smart and nice Twitter client on terminal.",