list fully supported and autopep8
[rainbowstream.git] / README.rst
index b73506b..ee15eb5 100644 (file)
@@ -20,21 +20,31 @@ Screencast: https://www.youtube.com/watch?v=tykCvPMJq8s
 Install\r
 -------\r
 \r
-You will need Python 2.7+ and pip.\r
+The quick way\r
+^^^^^^^^^^^^^\r
+\r
+You will need Python and pip (2.7.x or 3.x).\r
 \r
 .. code:: bash\r
 \r
     sudo pip install rainbowstream\r
+    # Python 3 users: sudo pip3 install rainbowstream\r
+\r
 \r
-or try with a virtualenv\r
+The recommended way\r
+^^^^^^^^^^^^^^^^^^^\r
+\r
+Use `virtualenv`_\r
 \r
 .. code:: bash\r
 \r
-    sudo pip install virtualenv # skip if you already have virtualenv\r
     virtualenv venv\r
-    source venv/bin/activate # use the brand new virtualenv.\r
+    # Python 3 users : use -p to specify your Python 3 localtion as below\r
+    # virtualenv -p /usr/bin/python3 venv\r
+    source venv/bin/activate\r
     pip install rainbowstream\r
 \r
+\r
 Usage\r
 -----\r
 \r
@@ -163,3 +173,4 @@ details
 .. _theme usage and customization: https://github.com/DTVD/rainbowstream/blob/master/theme.md\r
 .. _Create your own Twitter Application: https://apps.twitter.com/app/new\r
 .. _``rainbowstream``: https://github.com/DTVD/rainbowstream/tree/master/rainbowstream\r
+.. _virtualenv: http://docs.python-guide.org/en/latest/dev/virtualenvs/\r