bumped version
[rainbowstream.git] / README.md
index d5b53ef..a621318 100644 (file)
--- a/README.md
+++ b/README.md
@@ -17,23 +17,26 @@ Screenshot: (Click to see)
 ![rainbowstream](https://raw.githubusercontent.com/DTVD/rainbowstream/master/screenshot/RainbowStreamAll.png)
 
 ## Install
-You will need Python 2.7+ and pip.
-
+#### The quick way
+You will need Python and pip (2.7.x or 3.x).
 ```bash
 sudo pip install rainbowstream
+# Python 3 users: sudo pip3 install rainbowstream
 ```
 
-or try with a virtualenv
+#### The recommended way
+Use [virtualenv](http://docs.python-guide.org/en/latest/dev/virtualenvs/)
 ```bash
-sudo pip install virtualenv # skip if you already have virtualenv
 virtualenv venv
-source venv/bin/activate # use the brand new virtualenv.
+# Python 3 users : use -p to specify your Python 3 localtion as below
+# virtualenv -p /usr/bin/python3 venv
+source venv/bin/activate
 pip install rainbowstream
 ```
 
 
 ## Usage
-#### The stream
+
 Just type
 ```bash
 rainbowstream
@@ -95,6 +98,8 @@ CONSUMER_SECRET = 'APISecret' # Your Twitter application's API secret
 * Use pip to install in local
 ```bash
 # cd to directory which contains setup.py
+virtualenv venv # Python3 users: use -p to specify python3
+source venv/bin/activate
 pip install -e .
 pip list | grep rainbowstream # confirm installed version
 rainbowstream # local version of rainbowstream