merge with built mute dict
[rainbowstream.git] / setup.py
1 from setuptools import setup, find_packages
2 import os
3 import os.path
4
5 # Bumped version
6 version = '0.6.7'
7
8 # Require
9 install_requires = [
10 "python-dateutil",
11 "requests",
12 "pyfiglet",
13 "twitter",
14 "Pillow",
15 ]
16
17 # Copy default config if not exists
18 default = os.path.expanduser("~") + os.sep + '.rainbow_config.json'
19 if not os.path.isfile(default):
20 cmd = 'cp rainbowstream/colorset/config ' + default
21 os.system(cmd)
22 cmd = 'chmod 777 ' + default
23 os.system(cmd)
24
25 # Setup
26 setup(name='rainbowstream',
27 version=version,
28 description="A smart and nice Twitter client on terminal.",
29 long_description=open("./README.rst", "r").read(),
30 classifiers=[
31 "Development Status :: 5 - Production/Stable",
32 "Environment :: Console",
33 "Intended Audience :: End Users/Desktop",
34 "Natural Language :: English",
35 "Operating System :: OS Independent",
36 "Programming Language :: Python :: 2.7",
37 "Programming Language :: Python :: 3.2",
38 "Programming Language :: Python :: 3.3",
39 "Programming Language :: Python :: 3.4",
40 "Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
41 "Topic :: Utilities",
42 "License :: OSI Approved :: MIT License",
43 ],
44 keywords='twitter, command-line tools, stream API',
45 author='Vu Nhat Minh',
46 author_email='nhatminh179@gmail.com',
47 url='http://www.rainbowstream.org/',
48 license='MIT License',
49 packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
50 include_package_data=True,
51 zip_safe=True,
52 install_requires=install_requires,
53 entry_points="""
54 # -*- Entry points: -*-
55 [console_scripts]
56 rainbowstream=rainbowstream.rainbow:fly
57 """,
58 )