Twitter Error display bug in Python 3
[rainbowstream.git] / setup.py
1 from setuptools import setup, find_packages
2 import os
3 import os.path
4
5 # Bumped version
6 version = '1.1.9'
7
8 # Require
9 install_requires = [
10 "python-dateutil",
11 "arrow",
12 "requests",
13 "pyfiglet",
14 "twitter",
15 "Pillow",
16 "PySocks"
17 ]
18
19 # Copy default config if not exists
20 default = os.path.expanduser("~") + os.sep + '.rainbow_config.json'
21 if not os.path.isfile(default):
22 cmd = 'cp rainbowstream/colorset/config ' + default
23 os.system(cmd)
24 cmd = 'chmod 777 ' + default
25 os.system(cmd)
26
27 # Setup
28 setup(name='rainbowstream',
29 version=version,
30 description="A smart and nice Twitter client on terminal.",
31 long_description=open("./README.rst", "r").read(),
32 classifiers=[
33 "Development Status :: 5 - Production/Stable",
34 "Environment :: Console",
35 "Intended Audience :: End Users/Desktop",
36 "Natural Language :: English",
37 "Operating System :: OS Independent",
38 "Programming Language :: Python :: 2.7",
39 "Programming Language :: Python :: 3.2",
40 "Programming Language :: Python :: 3.3",
41 "Programming Language :: Python :: 3.4",
42 "Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
43 "Topic :: Utilities",
44 "License :: OSI Approved :: MIT License",
45 ],
46 keywords='twitter, command-line tools, stream API',
47 author='Vu Nhat Minh',
48 author_email='nhatminh179@gmail.com',
49 url='http://www.rainbowstream.org/',
50 license='MIT License',
51 packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
52 include_package_data=True,
53 zip_safe=True,
54 install_requires=install_requires,
55 entry_points="""
56 # -*- Entry points: -*-
57 [console_scripts]
58 rainbowstream=rainbowstream.rainbow:fly
59 """,
60 )