generate config file by default
[rainbowstream.git] / setup.py
1 from setuptools import setup, find_packages
2 import os, sys
3
4 # Bumped version
5 version = '0.3.5'
6
7 # Require
8 install_requires = [
9 "python-dateutil",
10 "requests",
11 "pyfiglet",
12 "SQLAlchemy",
13 "twitter",
14 "Pillow",
15 ]
16 # Python 3 doesn't hava pysqlite
17 if sys.version[0] == "2":
18 install_requires += ["pysqlite"]
19
20 # Copy default config if not exists
21 default = os.environ.get(
22 'HOME',
23 os.environ.get(
24 'USERPROFILE',
25 '')) + os.sep + '.rainbow_config.json'
26 if not os.path.isfile(default):
27 cmd = 'cp rainbowstream/colorset/config ' + default
28 os.system(cmd)
29
30 # Setup
31 setup(name='rainbowstream',
32 version=version,
33 description="A smart and nice Twitter client on terminal.",
34 long_description=open("./README.rst", "r").read(),
35 classifiers=[
36 "Development Status :: 5 - Production/Stable",
37 "Environment :: Console",
38 "Intended Audience :: End Users/Desktop",
39 "Natural Language :: English",
40 "Operating System :: OS Independent",
41 "Programming Language :: Python :: 2.7",
42 "Programming Language :: Python :: 3.4",
43 "Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
44 "Topic :: Utilities",
45 "License :: OSI Approved :: MIT License",
46 ],
47 keywords='twitter, command-line tools, stream API',
48 author='Vu Nhat Minh',
49 author_email='nhatminh179@gmail.com',
50 url='http://www.rainbowstream.org/',
51 license='MIT License',
52 packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
53 include_package_data=True,
54 zip_safe=True,
55 install_requires=install_requires,
56 entry_points="""
57 # -*- Entry points: -*-
58 [console_scripts]
59 rainbowstream=rainbowstream.rainbow:fly
60 """,
61 )