add info for pypi
[rainbowstream.git] / README.md
1 ## Rainbow Stream
2 Terminal-based Twitter Client with Streaming API support. Only supports Python 2.7 or later.
3
4 This package build on the top of [Python Twitter Tool](http://mike.verdone.ca/twitter/) and [Twitter Streaming API](https://dev.twitter.com/docs/api/streaming) and inspired by [EarthQuake](https://github.com/jugyo/earthquake)
5
6 ## Screenshot
7 ![v0.0.1](https://raw.githubusercontent.com/DTVD/rainbowstream/master/screenshot/RainbowStreamv0.0.1.png)
8
9 ## Install
10 **The easy way:**
11 * Clone this repo
12 * Create virtualenv (optional but recommended)
13 * Install dependencies
14 * Install the package itself
15
16 ```bash
17 git clone https://github.com/DTVD/rainbowstream.git
18 cd rainbowstream
19 virtualenv venv # Assume that you have virtualenv installed by "pip install virtualenv"
20 source venv/bin/activate
21 pip install -e .
22 ```
23 **The quick way:**
24 * Install everything over the air
25
26 ```bash
27 sudo pip install git+https://github.com/DTVD/rainbowstream.git
28 ```
29 **Note the I only support Python version 2.7+**
30
31 ## Usage
32 ```bash
33 rainbowstream
34 ```
35 In the first time you will be asked for authorization of Rainbow Stream app at Twitter.
36
37 Just click the "Authorize access" button and paste PIN number to the terminal, the rainbow will start.
38
39 ## License
40 Rainbow Stream are released under an MIT License. See LICENSE.txt for details