Test suite: disable OCSP for old openssl part 2
authorTodd Lyons <tlyons@exim.org>
Wed, 29 Oct 2014 14:50:41 +0000 (07:50 -0700)
committerTodd Lyons <tlyons@exim.org>
Wed, 29 Oct 2014 14:50:41 +0000 (07:50 -0700)
Make sure to only disable this if building for openssl, allow gnutls
  to build with OCSP for all versions that support it.

doc/doc-txt/ChangeLog
test/src/client.c

index ed45747..5a298d1 100644 (file)
@@ -59,6 +59,9 @@ JH/08 Rename the TPDA expermimental facility to Event Actions.  The #ifdef
       raised for inbound connections, if the main configuration event_action
       option is defined.
 
+TL/06 In test suite, disable OCSP for old versions of openssl which contained
+      early OCSP support, but no stapling (appears to be less than 1.0.0).
+
 
 Exim version 4.84
 -----------------
index 72cebbe..5b52916 100644 (file)
@@ -58,11 +58,6 @@ static int sigalrm_seen = 0;
 
 /* TLS support can be optionally included, either for OpenSSL or GnuTLS. The
 latter needs a whole pile of tables. */
-#if !defined(EXIM_HAVE_OPENSSL_TLSEXT) && !defined(DISABLE_OCSP)
-# warning "OpenSSL library version too old; define DISABLE_OCSP in Makefile"
-# define DISABLE_OCSP
-#endif
-
 #ifdef HAVE_OPENSSL
 # define HAVE_TLS
 # include <openssl/crypto.h>
@@ -71,6 +66,10 @@ latter needs a whole pile of tables. */
 # include <openssl/ssl.h>
 # include <openssl/err.h>
 # include <openssl/rand.h>
+# if !defined(EXIM_HAVE_OPENSSL_TLSEXT) && !defined(DISABLE_OCSP)
+#  warning "OpenSSL library version too old; define DISABLE_OCSP in Makefile"
+#  define DISABLE_OCSP
+# endif
 # ifndef DISABLE_OCSP
 #  include <openssl/ocsp.h>
 # endif