Warn updating folks to use $local_part_verified
authorPhil Pennock <pdp@exim.org>
Sat, 11 Jan 2020 23:51:28 +0000 (18:51 -0500)
committerPhil Pennock <pdp@exim.org>
Sat, 11 Jan 2020 23:51:28 +0000 (18:51 -0500)
This tainting change to appendfile seems likely to cause pain, breaking
previously working configurations.  Note it in README.UPDATING.

src/README.UPDATING

index db754da..94a1420 100644 (file)
@@ -25,6 +25,18 @@ there have been two big upheavals...
 The rest of this document contains information about changes in 4.xx releases
 that might affect a running system.
 
+
+Exim version 4.94
+-----------------
+
+Some Transports now refuse to use tainted data in constructing their delivery
+location; this WILL BREAK configurations which are not updated accordingly.
+
+In particular: any Transport use of $local_user which has been relying upon
+check_local_user far away in the Router to make it safe, should be updated to
+replace $local_user with $local_part_verified.
+
+
 Exim version 4.93
 -----------------