mk_exim_release: output an useful error message when used for older versions
authorHeiko Schlittermann (HS12-RIPE) <hs@schlittermann.de>
Thu, 20 Dec 2018 22:06:38 +0000 (23:06 +0100)
committerHeiko Schlittermann (HS12-RIPE) <hs@schlittermann.de>
Thu, 20 Dec 2018 22:06:38 +0000 (23:06 +0100)
Older releases can't be built with the newer mk_exim_release script,
as there are interdependencies with scripts/reversion and version.sh

release-process/scripts/mk_exim_release

index 2586517..5bda34c 100755 (executable)
@@ -68,6 +68,10 @@ package Context {
         $context->{v}{security} = $+{security};
         $context->{v}{rc} = $+{rc};
 
+        die "$ME: This script doesn't work for versions prior 4.92-RCx. Please checkout an older version.\n"
+            if $context->{v}{major} < 4
+            or $context->{v}{major} == 4 && $context->{v}{minor} < 92;
+
         ### v: $context->{v}
 
         # find a valid vcs tag matching the version