Test suite: disable OCSP for old openssl part 3
authorJeremy Harris <jgh146exb@wizmail.org>
Thu, 30 Oct 2014 20:32:14 +0000 (20:32 +0000)
committerJeremy Harris <jgh146exb@wizmail.org>
Thu, 30 Oct 2014 20:32:14 +0000 (20:32 +0000)
test/src/client.c

index 5b52916..3f3bbe9 100644 (file)
@@ -66,7 +66,8 @@ latter needs a whole pile of tables. */
 # include <openssl/ssl.h>
 # include <openssl/err.h>
 # include <openssl/rand.h>
-# if !defined(EXIM_HAVE_OPENSSL_TLSEXT) && !defined(DISABLE_OCSP)
+
+# if OPENSSL_VERSION_NUMBER < 0x0090806fL && !defined(DISABLE_OCSP) && !defined(OPENSSL_NO_TLSEXT)
 #  warning "OpenSSL library version too old; define DISABLE_OCSP in Makefile"
 #  define DISABLE_OCSP
 # endif