Document pkg-config for TLS
authorPhil Pennock <pdp@exim.org>
Sat, 18 Feb 2012 14:22:27 +0000 (09:22 -0500)
committerPhil Pennock <pdp@exim.org>
Sat, 18 Feb 2012 14:22:27 +0000 (09:22 -0500)
doc/doc-docbook/spec.xfpt
doc/doc-txt/ChangeLog
doc/doc-txt/NewStuff

index 46a92de..8afccbf 100644 (file)
@@ -1868,6 +1868,14 @@ SUPPORT_TLS=yes
 TLS_LIBS=-L/usr/local/openssl/lib -lssl -lcrypto
 TLS_INCLUDE=-I/usr/local/openssl/include/
 .endd
+.new
+.cindex "pkg-config" "OpenSSL"
+If you have &'pkg-config'& available, then instead you can just use:
+.code
+SUPPORT_TLS=yes
+USE_OPENSSL_PC=openssl
+.endd
+.wen
 .cindex "USE_GNUTLS"
 If GnuTLS is installed, you should set
 .code
@@ -1883,6 +1891,16 @@ USE_GNUTLS=yes
 TLS_LIBS=-L/usr/gnu/lib -lgnutls -ltasn1 -lgcrypt
 TLS_INCLUDE=-I/usr/gnu/include
 .endd
+.new
+.cindex "pkg-config" "GnuTLS"
+If you have &'pkg-config'& available, then instead you can just use:
+.code
+SUPPORT_TLS=yes
+USE_GNUTLS=yes
+USE_GNUTLS_PC=gnutls
+.endd
+.wen
+
 You do not need to set TLS_INCLUDE if the relevant directory is already
 specified in INCLUDE. Details of how to configure Exim to make use of TLS are
 given in chapter &<<CHAPTLS>>&.
@@ -2111,7 +2129,8 @@ binary, attempts to configure Exim to use it cause run time configuration
 errors.
 
 .new
-.cindex "pkg-config" "specifying"
+.cindex "pkg-config" "lookups"
+.cindex "pkg-config" "authenticators"
 Many systems now use a tool called &'pkg-config'& to encapsulate information
 about how to compile against a library; Exim has some initial support for
 being able to use pkg-config for lookups and authenticators.  For any given
index aa11372..699da32 100644 (file)
@@ -25,6 +25,9 @@ PP/04 Local/Makefile support for (AUTH|LOOKUP)_*_PC=foo to use
 PP/05 Swapped $auth1/$auth2 for gsasl GSSAPI mechanism, to be more consistent
       with rest of GSASL and with heimdal_gssapi.
 
+PP/06 Local/Makefile support for USE_(GNUTLS|OPENSSL)_PC=foo to use
+      `pkg-config foo` for cflags/libs for the TLS implementation.
+
 
 Exim version 4.77
 -----------------
index 1e5629c..487ce30 100644 (file)
@@ -26,7 +26,8 @@ Version 4.78
  3. The "pkg-config" system can now be used when building Exim to reference
     cflags and library information for lookups and authenticators, rather
     than having to update "CFLAGS", "AUTH_LIBS", "LOOKUP_INCLUDE" and
-    "LOOKUP_LIBS" directly.
+    "LOOKUP_LIBS" directly.  Similarly for handling the TLS library support
+    without adjusting "TLS_INCLUDE" and "TLS_LIBS".
 
 
 Version 4.77