tls_require_ciphers must be assigned to state copy
authorPhil Pennock <pdp@exim.org>
Sun, 20 May 2012 22:22:06 +0000 (18:22 -0400)
committerPhil Pennock <pdp@exim.org>
Sun, 20 May 2012 22:22:06 +0000 (18:22 -0400)
doc/doc-txt/ChangeLog
src/src/tls-gnu.c

index 21f1ec7..3d0f5c2 100644 (file)
@@ -134,6 +134,9 @@ PP/31 %D in printf continues to cause issues (-Wformat=security), so for
       As part of this, removing so much warning spew let me fix some minor
       real issues in debug logging.
 
+PP/32 GnuTLS was always using default tls_require_ciphers, due to a missing
+      assignment on my part.  Fixed.
+
 
 Exim version 4.77
 -----------------
index 51fdb86..9d121f9 100644 (file)
@@ -870,6 +870,7 @@ state->host = host;
 
 state->tls_certificate = certificate;
 state->tls_privatekey = privatekey;
+state->tls_require_ciphers = require_ciphers;
 state->tls_sni = sni;
 state->tls_verify_certificates = cas;
 state->tls_crl = crl;