Fix testsuite build on Solaris
[exim.git] / test / configure.ac
index 83f1aa05db7b365be510b10c0e8744b2eb6dafbe..a38b5b0ae34b6703c8df623a8e115f6948eda561 100644 (file)
@@ -48,6 +48,11 @@ case $host_os in
     ;;
 esac
 
     ;;
 esac
 
+dnl Solaris requires additional libraries for networking functions.
+
+AC_SEARCH_LIBS([inet_addr], [nsl])
+AC_SEARCH_LIBS([connect], [socket])
+
 dnl "Export" these variables
 
 AC_SUBST(BIND_8_COMPAT)
 dnl "Export" these variables
 
 AC_SUBST(BIND_8_COMPAT)
@@ -55,6 +60,7 @@ AC_SUBST(CLIENT_SSL)
 AC_SUBST(CLIENT_GNUTLS)
 AC_SUBST(LOADED)
 AC_SUBST(LOADED_OPT)
 AC_SUBST(CLIENT_GNUTLS)
 AC_SUBST(LOADED)
 AC_SUBST(LOADED_OPT)
+AC_SUBST(LIBS)
 
 dnl This must be last; it determines what files are written
 
 
 dnl This must be last; it determines what files are written