constification
[exim.git] / test / configure.ac
index 6467a0da9206f02fc3f49f60cd14d3386bd5592e..a38b5b0ae34b6703c8df623a8e115f6948eda561 100644 (file)
@@ -1,5 +1,3 @@
-dnl $Cambridge: exim/test/configure.ac,v 1.2 2007/01/23 11:01:10 ph10 Exp $
-
 dnl Process this file with autoconf to produce a configure script.
 
 dnl This is required at the start; the name is the name of a file
@@ -50,6 +48,11 @@ case $host_os in
     ;;
 esac
 
+dnl Solaris requires additional libraries for networking functions.
+
+AC_SEARCH_LIBS([inet_addr], [nsl])
+AC_SEARCH_LIBS([connect], [socket])
+
 dnl "Export" these variables
 
 AC_SUBST(BIND_8_COMPAT)
@@ -57,6 +60,7 @@ AC_SUBST(CLIENT_SSL)
 AC_SUBST(CLIENT_GNUTLS)
 AC_SUBST(LOADED)
 AC_SUBST(LOADED_OPT)
+AC_SUBST(LIBS)
 
 dnl This must be last; it determines what files are written