OpenSSL: fix build on earlier library versions
[exim.git] / test / scripts / 5600-OCSP-OpenSSL / 5602
1 # OCSP stapling, server, multiple leaf-certs
2 # This will fail on OpenSSL versions before 1.1.0
3 #
4 #
5 #
6 exim -z '1: Server sends good staple on request, to client requiring RSA auth'
7 ****
8 #
9 exim -bd -oX PORT_D -DSERVER=server
10 ****
11 exim -odf -DSELECTOR=auth_rsa rsa.auth@test.ex
12 Subject: test
13
14 .
15 ****
16 killdaemon
17 #
18 #
19 #
20 #
21 exim -z '2: Server sends good staple on request, to client preferring ECDSA auth'
22 ****
23 #
24 exim -bd -oX PORT_D -DSERVER=server
25 ****
26 exim -odf -DSELECTOR=auth_ecdsa ecdsa.auth@test.ex
27 Subject: test
28
29 .
30 ****
31 killdaemon
32 no_msglog_check