OpenSSL: fix build on earlier library versions
[exim.git] / test / scripts / 5600-OCSP-OpenSSL / 5602
CommitLineData
5b2fd993 1# OCSP stapling, server, multiple leaf-certs
012dd02e 2# This will fail on OpenSSL versions before 1.1.0
5b2fd993
JH
3#
4#
5#
6exim -z '1: Server sends good staple on request, to client requiring RSA auth'
7****
8#
9exim -bd -oX PORT_D -DSERVER=server
10****
11exim -odf -DSELECTOR=auth_rsa rsa.auth@test.ex
12Subject: test
13
14.
15****
16killdaemon
17#
18#
19#
20#
21exim -z '2: Server sends good staple on request, to client preferring ECDSA auth'
22****
23#
24exim -bd -oX PORT_D -DSERVER=server
25****
26exim -odf -DSELECTOR=auth_ecdsa ecdsa.auth@test.ex
27Subject: test
28
29.
30****
31killdaemon
32no_msglog_check